Compatibility Matrix

This table summarizes the compatibility between fiddler-client and Fiddler platform. You can find:

  • Corresponding Fiddler Platform(s): Exactly the same features / API objects in both python client and the Fiddler Platform version

  • Lower Fiddler Platform: Python client has features or API objects that may not be present in the Fiddler Platform, either due to that python client has additional new methods, or that the server has removed old APIs. However, everything they have in common (i.e., most APIs) will work.

  • Higher Fiddler Platform: The Fiddler Platform has features the python client can't use, either due to the server has additional new APIs, or that python client has removed old API. However, everything they share in common (i.e., most APIs) will work.

Client versionCorresponding Fiddler Platform(s) ✅Lower Fiddler PlatformHigher Fiddler Platform

3.0

24.4

Not compatible

2.5

24.2 and 24.3

24.1 or below

24.4 or above

2.4

24.1

23.7 or below

24.2 or above

2.3

23.7

23.6 or below

24.1 or above

2.2

23.6

23.5 or below

23.7 or above

2.1

23.5

23.4 or below

23.6 or above

2.0

23.4

23.3 or below

23.5 or above

1.8 (deprecated)

23.2 and 23.3

23.1 or below

23.4 or above

1.7 (deprecated)

23.1

22.12 or below

23.2 or above

Last updated

© 2024 Fiddler AI